본문 바로가기
네트워크 수업

23.04.14 OSPF CCIE 코드 정리

by 6^6 2023. 4. 14.
728x90

180v1 (1).zip
0.05MB

 

 

//R1
 enable
   
 conf t
 hostname R1
   
 int s1/0
 no sh
 encap fram
 no fram inverse
 clock rate 64000
   
 int lo 0
 ip add 1.1.1.1 255.255.255.0
   
 do show frame-relay pvc | include DLCI
   
 int s1/0.1 m
 ip add 1.1.11.1 255.255.255.0
 ip ospf hello-interval 10
 fram map ip 1.1.11.2 102 br
 fram map ip 1.1.11.3 103 br
   
 int f0/0
 no sh
 ip add 1.1.17.1 255.255.255.0
   
 int f0/1
 no sh
 ip add 1.1.18.1 255.255.255.0
   
 router ospf 1
 router-id 1.1.1.1
 network 1.1.11.1 0.0.0.0 area 11
 network 1.1.1.1 0.0.0.0 area 0
 network 1.1.17.1 0.0.0.0 area 0
 network 1.1.18.1 0.0.0.0 area 0

//R2
 enable
   
 conf t
 hostname R2
   
 int s1/0
 no sh
 encap fram
 no fram inverse
 clock rate 64000
   
 do show frame-relay pvc | include DLCI
   
 int s1/0.2 p
 ip add 1.1.11.2 255.255.255.0
 fram inter 201
   
 int lo0
 ip add 1.1.2.2 255.255.255.0
   
 router ospf 1
 router-id 1.1.2.2
 network 1.1.2.2 0.0.0.0 area 11
 network 1.1.12.2 0.0.0.0 area 11

//R3
 enable
   
 conf t
 hostname R3
   
 int s1/0
 no sh
 encap fram
 no fram inverse
 clock rate 64000
   
do show frame-relay pvc | include DLCI
   
 int s1/0.3 p
 ip add 1.1.11.3 255.255.255.0
 fram inter 301
   
 int lo0
 ip add 1.1.3.3 255.255.255.0
   
 router ospf 1
 router-id 1.1.3.3
 network 1.1.3.3 0.0.0.0 area 11
 network 1.1.11.3 0.0.0.0 area 11

//SW1
 enable
   
 conf t
 hostname SW1
   
 vlan 100
   
 int range f1/1 - 2
 sw tr en do
 sw mo tr
 channel-group 1 mode on
   
 do sh eth summary
   
 int vlan 100
 ip add 1.1.79.7 255.255.255.0
   
 int lo0
 ip add 1.1.7.7 255.255.255.0
   
 int f1/0
 no switchport
 ip add 1.1.17.7 255.255.255.0
   
 int f1/10
 no switchport
 ip add 1.1.78.7 255.255.255.0
   
 router ospf 1
 router-id 1.1.7.7
 network 1.1.7.7 0.0.0.0 area 0
 network 1.1.17.7 0.0.0.0 area 0
 network 1.1.78.7 0.0.0.0 area 0
 network 1.1.79.7 0.0.0.0 area 78

//SW3
 enable
   
 conf t
 hostname SW3
   
 vlan 100
   
 int range f1/1 - 2
 sw tr en do
 sw mo tr
 channel-group 1 mode on
   
 do sh eth summary
   
 int lo0
 ip add 1.1.9.9 255.255.255.0
   
 int vlan 100
 ip add 1.1.79.9 255.255.255.0
   
 router ospf 1
 router-id 1.1.9.9
 network 1.1.9.9 0.0.0.0 area 78
 network 1.1.79.9 0.0.0.0 area 78

//SW2
 enable
   
 conf t
 hostname SW2
   
 vlan 100
   
 int range f1/1 - 2
 sw mo ac
 sw ac vlan 100
 channel-group 2 mode on
   
 do sh eth summary
   
 int vlan 100
 ip add 1.1.108.8 255.255.255.0
   
 int lo0
 ip add 1.1.8.8 255.255.255.0
   
 int f1/0
 no switchport
 ip add 1.1.18.8 255.255.255.0
   
 int f1/10
 no switchport
 ip add 1.1.78.8 255.255.255.0
   
 router ospf 1
 router-id 1.1.8.8
 network 1.1.18.8 0.0.0.0 area 0
 network 1.1.78.8 0.0.0.0 area 0
 network 1.1.8.8 0.0.0.0 area 0
 network 1.1.108.8 0.0.0.0 area 108

//SW4
 enable
   
 conf t
 hostname SW4
   
 vlan 100
   
 int range f1/1 - 2
 sw mo ac
 sw ac vlan 100
 channel-group 2 mode on
   
 do sh eth summary
   
 int vlan 100
 ip add 1.1.108.10 255.255.255.0
   
 int lo0
 ip add 1.1.10.10 255.255.255.0
   
 router ospf 1
 router-id 1.1.10.10
 network 1.1.10.10 0.0.0.0 area 108
 network 1.1.108.10 0.0.0.0 area 108


 

 

 

ena
conf t
no ip domain lookup
line c 0
exec-timeout 0
 logg sy
exit
host

 

SW1,2,3,4
 vlan 100
exit

SW1(config)#do show cdp neigh 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW2              Fas 1/10           145         R S I     3660      Fas 1/10
SW3              Fas 1/2            145         R S I     3660      Fas 1/2
SW3              Fas 1/1            145         R S I     3660      Fas 1/1

 

SW1(config)#int range f1/1 - 2

SW1(config-if-range)#sw tr enc dot
SW1(config-if-range)#sw mo tr

SW1(config-if-range)#channel-group 1 mode on

SW3(config)#do show cdp neigh
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW1              Fas 1/2            122         R S I     3660      Fas 1/2
SW1              Fas 1/1            122         R S I     3660      Fas 1/1
SW3(config)#int range f1/1 - 2
SW3(config-if-range)#sw tr enc dot
SW3(config-if-range)#sw mo tr
SW3(config-if-range)#channel-group 1 mode on

SW2(config)#do show cdp neigh
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW4              Fas 1/2            148         R S I     3660      Fas 1/2
SW4              Fas 1/1            148         R S I     3660      Fas 1/1
SW1              Fas 1/10           176         R S I     3660      Fas 1/10

 

SW2(config)#int range f1/1 - 2
SW2(config-if-range)#sw mode access 

SW2(config-if-range)#sw acc vlan 100

SW2(config-if-range)#channel-group 2 mode on

 

SW4(config)#do show cdp neig
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW2              Fas 1/2            151         R S I     3660      Fas 1/2
SW2              Fas 1/1            151         R S I     3660      Fas 1/1
SW4(config)#int range f1/1 - 2
SW4(config-if-range)#sw mode access
SW4(config-if-range)#sw acc vlan 100

SW4(config-if-range)#channel-group 2 mode on

 

SW1#show ether summary

Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa1/1(P)   Fa1/2(P) 

 

SW2#show ether summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
2     Po2(SU)     Fa1/1(P)   Fa1/2(P)  

 

 

SW3#show ether summary
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa1/1(P)   Fa1/2(P)

 

SW4#show ether summary
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
2     Po2(SU)     Fa1/1(P)   Fa1/2(P) 

 

 

//cdp neighbor 모를경우

SW1(config)#cdp run

 

R1(config)#int f0/1
R1(config-if)#no shut
R1(config-if)#int f0/0
R1(config-if)#no shut

SW1(config)#do show cdp neigh
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW2              Fas 1/10           148         R S I     3660      Fas 1/10
SW3              Fas 1/2            160         R S I     3660      Fas 1/2
SW3              Fas 1/1            160         R S I     3660      Fas 1/1
R1               Fas 1/0            149         R S I     3660      Fas 0/0

 

SW1(config)#int f1/0
SW1(config-if)#no sw
SW1(config-if)#ip add 1.1.17.7 255.255.255.0
SW1(config-if)#exit
SW1(config)#do show cdp neigh
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW2              Fas 1/10           167         R S I     3660      Fas 1/10
SW3              Fas 1/2            179         R S I     3660      Fas 1/2
SW3              Fas 1/1            179         R S I     3660      Fas 1/1
R1               Fas 1/0            168         R S I     3660      Fas 0/0

 

SW1(config)#int f1/10
SW1(config-if)#no sw
SW1(config-if)#ip add 1.1.78.7 255.255.255.0

SW1(config)#int f1/0
SW1(config-if)#no sw
SW1(config-if)#ip add 1.1.17.7 255.255.255.0
SW1(config-if)#exit
SW1(config)#int vlan 100  //svi에 ip넣기
SW1(config-if)#ip add 1.1.79.7 255.255.255.0
SW1(config-if)#int loo0 
SW1(config-if)#ip add 1.1.7.7 255.255.255.0

 

 

SW2(config)#cdp run
SW2(config)#int loo0
SW2(config-if)#ip add 1.1.8.8 255.255.255.0

SW2(config-if)#int vlan 100  //L2니까 no switchport 할 필요없다.

SW2(config-if)#ip add 1.1.108.8 255.255.255.0

 

맥이 낮은게 루트가 된다.

백본쪽에있는게 루트가 된다. (33분쯤) 아님 priority를 강제로 줘야함.

 

SW2(config-if)#do show cdp neigh
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW4              Fas 1/2            146         R S I     3660      Fas 1/2
SW4              Fas 1/1            146         R S I     3660      Fas 1/1
SW1              Fas 1/10           165         R S I     3660      Fas 1/10
R1               Fas 1/0            170         R S I     3660      Fas 0/1

 

 

SW2(config-if)#int f1/10
SW2(config-if)#no switchport
SW2(config-if)#ip add 1.1.78.8 255.255.255.0
SW2(config-if)#exit

SW2(config-if)#do show cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW4              Fas 1/2            120         R S I     3660      Fas 1/2
SW4              Fas 1/1            120         R S I     3660      Fas 1/1
SW1              Fas 1/10           120         R S I     3660      Fas 1/10
R1               Fas 1/0            134         R S I     3660      Fas 0/1

 

SW2(config-if)#int f1/0
SW2(config-if)#no swi
SW2(config-if)#ip add 1.1.18.8 255.255.255.0

 

SW2(config-if)#do show ip route
     1.0.0.0/24 is subnetted, 4 subnets
C       1.1.8.0 is directly connected, Loopback0
C       1.1.18.0 is directly connected, FastEthernet1/0
C       1.1.78.0 is directly connected, FastEthernet1/10
C       1.1.108.0 is directly connected, Vlan100

 

SW3(config)#int lo0

SW3(config-if)#ip add 1.1.9.9 255.255.255.0
SW3(config-if)#int vlan 100
SW3(config-if)#ip add 1.1.79.9 255.255.255.0

 

SW3(config-if)#do show ip route
     1.0.0.0/24 is subnetted, 2 subnets
C       1.1.9.0 is directly connected, Loopback0
C       1.1.79.0 is directly connected, Vlan100

 

SW4(config)#int loo0
SW4(config-if)#ip add 1.1.10.10 255.255.255.0
SW4(config-if)#int vlan 100
SW4(config-if)#ip add 1.1.108.10 255.255.255.0


SW4(config-if)#do show ip route
     1.0.0.0/24 is subnetted, 2 subnets
C       1.1.10.0 is directly connected, Loopback0
C       1.1.108.0 is directly connected, Vlan100

 

 


R1(config-if)#int s1/0
R1(config-if)#no shut
R1(config-if)#int s1/0
R1(config-if)# no sh
R1(config-if)# encap fram
R1(config-if)# no fram inverse
R1(config-if)# clock rate 64000
   
R1(config-if)#int s1/0.1 m
R1(config-subif)# ip add 1.1.11.1 255.255.255.0
R1(config-subif)# fram map ip 1.1.11.2 102 br
R1(config-subif)# fram map ip 1.1.11.3 103 br

 

R1(config-if)# int lo0
R1(config-if)# ip add 1.1.1.1 255.255.255.0

do show cdp neigh

 

R1(config-if)# int f0/0
R1(config-if)# ip add 1.1.17.1 255.255.255.0

R1(config-if)# int f0/1
R1(config-if)# ip add 1.1.18.1 255.255.255.0

R1(config-if)#do show ip route

 

 

 

R2(config)# int s1/0
R2(config-if)# no sh
R2(config-if)# encap fram
R2(config-if)# no fram inverse
R2(config-if)# clock rate 64000

R2(config-if)# int s1/0.2 p
R2(config-subif)# ip add 1.1.11.2 255.255.255.0
R2(config-subif)# fram inter 201

R2(config-fr-dlci)# int lo0
R2(config-if)# ip add 1.1.2.2 255.255.255.0

R2(config-if)#do show ip route
     1.0.0.0/24 is subnetted, 2 subnets
C       1.1.2.0 is directly connected, Loopback0
C       1.1.11.0 is directly connected, Serial1/0.2

 

 

 

R3(config)#int s1/0
R3(config-if)# no sh
R3(config-if)# encap fram
R3(config-if)# no fram inverse
R3(config-if)# clock rate 64000

R3(config-if)# int s1/0.3 p
R3(config-subif)# ip add 1.1.11.3 255.255.255.0
R3(config-subif)# fram inter 301
R3(config-fr-dlci)# int lo0
R3(config-if)# ip add 1.1.3.3 255.255.255.0

 


낯선장비 안에 DLCI값이 어떤지 모른다. 모르는게 정상이다.

그럼 LMI를 통해서 알수있다. 프레임릴레이 직접가지 않고!

 

do show frame-relay pvc | include DLCI

//프레임릴레이가 부산에 있다고했을때, DLCI값을 부산에있는 노트북을 띄어보지않고 알 수 있는것!

R1(config-subif)#do show frame-relay pvc | include DLCI
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

 

R3(config-if)#do show frame-relay pvc | include DLCI
DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.3
DLCI = 302, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

 

R2(config-if)#do show frame-relay pvc | include DLCI
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.2
DLCI = 203, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

 

 

SW1(config-if)# router ospf 1
SW1(config-router)# router-id 1.1.7.7
SW1(config-router)# network 1.1.7.7 0.0.0.0 area 0
SW1(config-router)# network 1.1.17.7 0.0.0.0 area 0
SW1(config-router)# network 1.1.78.7 0.0.0.0 area 0
SW1(config-router)# network 1.1.79.7 0.0.0.0 area 78

 

 

SW2(config-if)# router ospf 1 
SW2(config-router)# router-id 1.1.8.8
SW2(config-router)# network 1.1.18.8 0.0.0.0 area 0
SW2(config-router)# network 1.1.78.8 0.0.0.0 area 0
SW2(config-router)# network 1.1.8.8 0.0.0.0 area 0
SW2(config-router)# network 1.1.108.8 0.0.0.0 area 108

 

 

SW3(config)# router ospf 1
SW3(config-router)# router-id 1.1.9.9
SW3(config-router)# network 1.1.9.9 0.0.0.0 area 78
SW3(config-router)# network 1.1.79.9 0.0.0.0 area 78

 

 

SW4(config-if)# router ospf 1
SW4(config-router)# router-id 1.1.10.10
SW4(config-router)# network 1.1.10.10 0.0.0.0 area 108
SW4(config-router)# network 1.1.108.10 0.0.0.0 area 108

 

 

R1(config-subif)# router ospf 1
R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 1.1.11.1 0.0.0.0 area 11
R1(config-router)# network 1.1.1.1 0.0.0.0 area 0
R1(config-router)# network 1.1.17.1 0.0.0.0 area 0
R1(config-router)# network 1.1.18.1 0.0.0.0 area 0

 

R2(config-if)# router ospf 1
R2(config-router)# router-id 1.1.2.2
R2(config-router)# network 1.1.2.2 0.0.0.0 area 11
R2(config-router)# network 1.1.11.2 0.0.0.0 area 11

 

R3(config-if)# router ospf 1
R3(config-router)# router-id 1.1.3.3
R3(config-router)# network 1.1.3.3 0.0.0.0 area 11
R3(config-router)# network 1.1.11.3 0.0.0.0 area 11

 

근데 R1,2,3는 neighbor를 안맺는다. 왜? p-to-p 와 p-to-multi 인터페이스 타입이 틀리기 때문에!

do show ip ospf int s1/0

 

R1(config)#do show ip ospf int s1/0.1
Serial1/0.1 is up, line protocol is up 
  Internet Address 1.1.11.1/24, Area 11 
  Process ID 13, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64  //NBMA다

 

R3(config)#do show ip ospf int s1/0.3
Serial1/0.3 is up, line protocol is up 
  Internet Address 1.1.11.3/24, Area 11 
  Process ID 13, Router ID 1.1.3.3, Network Type POINT_TO_POINT, Cost: 64

 

//p-to-p는 hello가 10초고, p-to-multi 는 hello가 30초다. hello가 다르면 neighbor를 맺지 않는다.

//hello가 같더라도 DR를 뽑는애들끼리, 안뽑는애들끼리만 neighbor을 맺는다.

//최적의 컨버젼스 타임을 갖게하려 neighbor을 최대한 빨리 맺게하라는 뜻.

//wait타임 없는것.  p-to-p와 p-to-multi가 wait타임 없다.

Dead time = Wait time

컨버젼스 타임이란 = 갱신 기간

DR을 안뽑게되면 Hello의 4배를 절약하게 된다.

 

show frame-relay pvc | include DLCI

 

R2 R3는 p-to-p로 간다.

multi는 nbma로 인식하고 p-to-p는 로 인식한다.

 

R1(config)#int s1/0.1
R1(config-subif)#ip ospf net point-to-m  //p-to-p는 안됨. R1에 R2와 R3가 연결되어있으니까!
R1(config-subif)#ip ospf hello-interval 10 

//이러면 neighbor를 자동으로 맺는다.

 

 

 

R1(config-router)#do show ip route
     1.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
O IA    1.1.10.10/32 [110/3] via 1.1.18.8, 03:05:30, FastEthernet0/1
O IA    1.1.9.9/32 [110/3] via 1.1.17.7, 03:05:30, FastEthernet0/0
O       1.1.8.8/32 [110/2] via 1.1.18.8, 03:05:30, FastEthernet0/1
O       1.1.7.7/32 [110/2] via 1.1.17.7, 03:05:30, FastEthernet0/0
O       1.1.3.3/32 [110/65] via 1.1.11.3, 03:05:15, Serial1/0.1
O       1.1.2.2/32 [110/65] via 1.1.11.2, 03:05:25, Serial1/0.1
C       1.1.1.0/24 is directly connected, Loopback0
C       1.1.11.0/24 is directly connected, Serial1/0.1
C       1.1.17.0/24 is directly connected, FastEthernet0/0
C       1.1.18.0/24 is directly connected, FastEthernet0/1
O       1.1.78.0/24 [110/2] via 1.1.18.8, 03:05:31, FastEthernet0/1
                    [110/2] via 1.1.17.7, 03:05:31, FastEthernet0/0
O IA    1.1.79.0/24 [110/2] via 1.1.17.7, 03:05:35, FastEthernet0/0
O IA    1.1.108.0/24 [110/2] via 1.1.18.8, 03:05:35, FastEthernet0/1

//32bit 이상한 애들 어떻게 잡음?

//모든 loopback 0 에다가 ip ospf net point-to-point 넣어줌.

 

R1,2,3 SW1,2,3,4

#int loo0
#ip ospf net point-to-point

 

OSPF Metric공식 = 10^8(1억)/BW

 

SW1에서

1.1.9.0로는 200M/bps 로 가야하고

1.1.8.0로는 100M/bps 로 가야하는데

SW1(config-if)#do show ip rou 
O       1.1.8.0/24 [110/2] via 1.1.78.8, 00:00:57, FastEthernet1/10
O       1.1.9.0/24 [110/2] via 1.1.79.9, 00:01:27, Vlan100

[신뢰도/목적지까지 가기위한 OSPF Metric]

Metric 두배가 차이나야하는데 똑같다....(왼쪽은 Ether-Channel, 오른쪽은 한가닥...(?)). 엔지니어라면 이런걸 유심히 볼수있는 눈이 있어야함.

SW1#show cdp nei
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW2              Fas 1/10           147         R S I     3660      Fas 1/10
SW3              Fas 1/2            177         R S I     3660      Fas 1/2
SW3              Fas 1/1            177         R S I     3660      Fas 1/1
R1               Fas 1/0            161         R S I     3660      Fas 0/0

 

SW1#show int f1/10
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

 

SW1#show ip int brie
Interface                  IP-Address      OK? Method Status                Protocol
Port-channel1              unassigned      YES unset  up                    up

 

SW1#show int port-channel 1  //논리적으로 묶은 포트 조회.
  MTU 1500 bytes, BW 200000 Kbit/sec, DLY 1000 usec

 

SW1#show int vlan 100  //SVI 조회
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

 

SW1,2

#bandwidth 200000   //200,000으로 바꿔줌.
#do show int vlan 100
  MTU 1500 bytes, BW 200000 Kbit/sec, DLY 100 usec

 

 

SW1(config-if)#do show ip route
O       1.1.8.0/24 [110/2] via 1.1.78.8, 00:34:31, FastEthernet1/10
O       1.1.9.0/24 [110/2] via 1.1.79.9, 00:35:01, Vlan100

//하지만 아직 변하지 않았다...

//1,000,000/1,000,000 = 1 

//1,000,000/2,000,000 = 0.5 = 1

//결국 1이기 때문.

//분자를 높이자.

 

 

//

이럴 경우 OSPF 기준 대역폭을 증가시켜야 한다.
OSPF설정모드에서 auto-cost reference-bandwidth 명령어를 사용.
★Mbis per second 는 M = 10^6이다.★

//

 

//SW1,2,3,4 모두에게 router ospf 1에다가 BW 1000을준다.

#router ospf 1
#auto-cost reference-bandwidth 1000(0000)
% OSPF: Reference bandwidth is changed. 
        Please ensure reference bandwidth is consistent across all routers.

SW1,2

#clear ip ospf process
#Reset ALL OSPF processes? [no]: y

 

이더채널이 더 빠르게 됨.

 

또한, 인터페이스에서 cost를 직접 바꿀 수 있다.
ip ospf cost ?
<1-65535> cost 
//수업시간엔 왜 이방법을 안썼지...?


 

os 7 layer가 있고

ibm의 sma 가 있다 => ip 주소체계를 안쓴다. 

 

먼저 브릿지 그룹을 만들어야한다.

 

SW1(config)#bridge 1 protocol vlan-bridge   
SW1(config)#interface vlan 100
SW1(config-if)#bridge-group 1     
SW1(config-if)#exit
SW1(config)#int f1/10
SW1(config-if)#bridge-group 1

R1(config)#router ospf 1
R1(config-router)#area 11 stub no-summary

 


R2(config-router)#router ospf 1
R2(config-router)#area 11 stub

 

R3#clear ip route *

 

R3#sho ip route 

디폴트 빼고 다 싹사라짐

 

R3#show logging

Syslog logging: enabled (11 messages dropped, 0 messages rate-limited,
                0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.



No Inactive Message Discriminator.


    Console logging: level debugging, 42 messages logged, xml disabled,  //현재 화면에 띄어져있는 로긴메시지
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,  //다른 장비의 화면을 띄울수있다. 
                     filtering disabled
    Buffer logging:  disabled, xml disabled,  // 메모리에 저장되어있는 것을 버퍼 로깅이라고한다.
                     filtering disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

 

R3(config)#logging console ?   //숫자가 낮을수록 심각하다... 
  <0-7>          Logging severity level
  alerts         Immediate action needed           (severity=1)
  critical       Critical conditions               (severity=2)
  debugging      Debugging messages                (severity=7)
  discriminator  Establish MD-Console association
  emergencies    System is unusable                (severity=0)
  errors         Error conditions                  (severity=3)
  filtered       Enable filtered logging
  guaranteed     Guarantee console messages
  informational  Informational messages            (severity=6)
  notifications  Normal but significant conditions (severity=5)
  warnings       Warning conditions                (severity=4)
  xml            Enable logging in XML
//0번은 이멀전씨다. 매우 심각...!!! 

 

R3(config)#int s1/0        
R3(config-if)#sh
R3(config-if)#
*Mar  1 03:11:48.583: %LINK-5-CHANGED:  //level5 다.

 

R3(config-if)#logging console 4
R3(config)#int s1/0
R3(config-if)#shu
R3(config-if)#no shut
R3(config-if)#
*Mar  1 03:12:44.331: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up //no shut은 심각도가 3

 

logging console 뒤에 숫자를 넣어주면 그 숫자보다 더 심각한 상태일때만 콘솔창에 표시해준다.

7번이 기본값이다.

 

5번 - 2

R3(config)#logging buffered 8192

//화면의 심각도에 따라 콘솔창에 뿌릴지 말지 정할수있다.

 

5번 - 3

R3(config)#logging ?

 count  Count every log message and timestamp last occurrence


R3(config)#logging count 

 

 

 

R1

 

문제 b.

logging buffered 8192 3  //이렇게하면 1하고 3이 한번에 뿌려짐

 

문제 c.

service timestamps log datetime

 

문제 d.

logging count

 

 

//logging console의 기본값은 7

 

 

 

728x90

'네트워크 수업' 카테고리의 다른 글

메일서버 23.04.18  (0) 2023.04.18
23.04.17  (0) 2023.04.17
[네트워크] OSPF / Frame-Relay 23.04.13  (0) 2023.04.13
23.04.13 OSPF  (0) 2023.04.13
[실습] OSPF 23.04.11  (0) 2023.04.11

댓글