4.4.0.0
기본설정
공통]
ena
conf t
no ip domain lookup
line c 0
logg sy
exec-timeout 0
exit
int s1/0
no shut
encapsulation frame-relay
no frame-relay inverse-arp
clock rate 64000
[R1]
hostname R1
int lo0
ip add 4.4.1.1 255.255.255.0
int s1/0
ip address 4.4.12.1 255.255.255.0
frame-relay map ip 4.4.12.2 102 br
R2]
hostname R2
int lo0
ip add 4.4.2.2 255.255.255.0
int s1/0.12 m
ip add 4.4.12.2 255.255.255.0
frame map ip 4.4.12.1 201 br
exit
int s1/0.23 m
ip address 4.4.23.2 255.255.255.0
frame map ip 4.4.23.3 203 br
R3]
hostname R3
int lo0
ip add 4.4.3.3 255.255.255.0
int s1/0.23 m
ip add 4.4.23.3 255.255.255.0
frame-relay map ip 4.4.23.2 302 br
exit
int s1/0.34 p
ip add 4.4.34.3 255.255.255.0
frame interface-dlci 304
R4]
hostname R4
int lo0
ip add 4.4.4.4 255.255.255.0
int s1/0.34 p
ip add 4.4.34.4 255.255.255.0
frame interface-dlci 403
[eigrp]
r1]
router eigrp 4
eigrp router-id 4.4.1.1
net 4.4.1.1 0.0.0.0
net 4.4.12.1 0.0.0.0
no auto
passive-interface lo0
r2]
router eigrp 4
eigrp router-id 4.4.2.2
net 4.4.2.2 0.0.0.0
net 4.4.23.2 0.0.0.0
net 4.4.34.2 0.0.0.0
no auto
passive-interface lo0
r3]
router eigrp 4
eigrp router-id 4.4.3.3
net 4.4.3.3 0.0.0.0
net 4.4.23.3 0.0.0.0
net 4.4.34.3 0.0.0.0
no auto
passive-interface lo0
r4]
router eigrp 4
eigrp router-id 4.4.4.4
net 4.4.4.4 0.0.0.0
net 4.4.34.4 0.0.0.0
no auto
passive-interface lo0
R2]]
int loo5
ip add 5.5.0.1 255.255.255.0
ip add 5.5.1.1 255.255.255.0 sec
ip add 5.5.2.1 255.255.255.0 sec
ip add 5.5.3.1 255.255.255.0 sec
router eigrp 4
network 5.5.0.0 0.0.3.255
int s1/0.12 m
ip summary-address eigrp 4 5.5.0.0 255.255.252.0
//show run 해보면 ip summary-address eigrp 4 5.5.0.0 255.255.252.0 5 라고 나온다. (축약 네트워크가 AD값이 5라는 뜻=최우선 라우팅이 된다. 90보다 훨씬 작으니까!!)
//근데 R1에서 확인해보면 5.5.0.0 대는 90이 된다.
//r2에서 다시 show ip route해보면
R1(config)#int s1/0
R1(config-if)#ip summary-address eigrp 4 0.0.0.0 0.0.0.0
R1이 R2 쪽으로 디폴트 라우팅을 줬다. 0.0.0.0 0.0.0.0
R1이 5.5.1.1 로 통신을 시도했다 가정.
라우팅테이블에 summary한게 있어서 갔는데 R2에 5.5.1.1 이 죽어있다.
근데 R1에서 디폴트로 줬으니까 계속 루프루프 돌고돌고 ..
그럼 이걸 방지하기 위해서 뭐가 있느냐.
R2 에서 show ip route 하면 롱기스트매치롤에 따른 5.5.0.0/22 is a summary null0 을 참고해서 루프를 안돌게 된다. null0는 루프 방지용이다.! ==>이게 무조건 생긴다.
축약한 라우팅에서 null0가 생기고 ad값이 5 이생긴다
null0하세요랑 축약하세요 랑 같은말이다.
R2]
R3쪽으로 디폴트 주기
R2(config-subif)#int s1/0.23
R2(config-subif)#ip summary-addres eigrp 4 0.0.0.0 0.0.0.0 //모든 라우터에 다 오른족으로 디폴트 준다.
R3]
int s1/0.34
ip summary-address eigrp 4 0.0.0.0 0.0.0.0
R2]
일단 어지러우니까 다 지워주기
no int lo5
router eigrp 4
no net 5.5.0.0
R4]
show ip route
R1]
show run
해보면 D*이 와있다는것을 알수있다. (0.0.0.0/0 Null0)
저건 R3가 준것. (R4야 넌 R3한테 오기만하면돼)
Summary한 라우터에서는 Null0가 생기니까
R3]
도 do show ip route해보면
근데 여기서 의문인건 R2가 준 디폴트 라우팅은?? 증발해버렸다.....??
왜...?? R2가 준건 AD값이 90이고 R3이 축약해준건 AD값이 5이기 때문에 R2가 준건 저장이 안되는것이다.
만약에,
R4가 4.4.2.2로 통신을 시도해본다면 어떻게 될까? (R2가 R3한테 디폴트값을 줬으니까 R3한텐 2.2값이 없다. null0값에 의해 뭉개졌기 때문..) 그래서 R4에서 ping 4.4.2.2 해보면 안된다.. R3은 블랙홀이 되었다...
그럼 어떻게 해야할까???
R3 의 null0값이 R2의 디폴트 라우팅AD값보다 더 높아져서 우선순위가 아지게 해주면된다.
R3]
int s1/0.23
no ip summary-address eigrp 4 0.0.0.0 0.0.0.0
ip summary-address eigrp 4 0.0.0.0 0.0.0.0 100
이제 R3는 R2를 바라보게 됐다!
R4에 show ip route하면
R3가 AD값을 100으로 줬다하더라도 R4에게 넘어오면 AD이 90으로 바뀌기때문에 R4가 R3를 바라보는건 변함없다.
R4에서 ping 4.4.2.2 하면 핑 성공!
R2에서도 마찬가지로 축약 디폴트 라우팅 AD값을 90보다 크게 넣어준다.
R2]
int s1/0.23
no ip summary-address eigrp 4 0.0.0.0 0.0.0.0
ip summary-address eigrp 4 0.0.0.0 0.0.0.0 100
do show ip route 하면
D* 0.0.0.0/0 [90/3123132] via 4.4.12.1, 00:01:06, Null0 로 간다.
2023.03.27 - [네트워크 수업] - EIGRP 개론.pdf 23.03.27
Feasible succesor에 대하여
(맨처음부터 R1의 오류로 R1관련 실습은 선생님거 캡처로.....)
summary 한거 다 지우기(100 넣어준거 그대로 똑같이 지워야함)
R1]
int loo0
shut
deb eigrp packets update //아무리..기다려도... 아무것도... 안나온다.....
int loo0
no shut 하면
EIGRP가 업데이트됐다는 알림이 뜬다.
R1#debug eigrp packets query //query 는
R1에서 loop0을 shut시키면 R1이 루프백 가는길을 몰라서 R2에게 물어본다.(loop은 Feasible succesor이기 때문)
int loo0
shut
시키면
R1#deb eigrp packets reply
R1(config)#int lo0
R1(config-if)#no shut
R1(config-if)#shut //=>쿼리에 대한 reply는 받는다.
query에대한 reply를 못오게 막자
R1]
ip access-list extended NO_EIGRP
deny eigrp host 4.4.12.2 any
permit ip any any
int s1/0
ip access-group NO_EIGRP in
shut
하고
R1#deb eigrp packets reply query
해보면
쿼리를 보낸다.
R1#show ip eigrp topology detail-link
==> 3분지나서 neighbor 끊어졌다. => SIA현상(Stuck In Active)
이 현상때문에 요즘엔 OSPF를 쓴다. 회사에서 neighbor 끊기면 절단나기때문.....
R1# show ip eigrp neighbor 하면 보이지도 않는다.
다시 취소하면
int s1/0
no ip access-group NO_EIGRP in
neighbor맺을것이다.
'네트워크 수업' 카테고리의 다른 글
[실습] OSPF, EIGRP 23.04.06 (0) | 2023.04.06 |
---|---|
OSPF 23.04.04 (0) | 2023.04.04 |
[리눅스] 23.03.31 (0) | 2023.03.31 |
외워야할 이론 23.03.30 23.03.31 (0) | 2023.03.30 |
[실습] EIGRP 부하분산(2) 23.03.29 (0) | 2023.03.29 |
댓글