본문 바로가기
네트워크 수업

[실습] EIGRP와 RIP 23.03.27

by 6^6 2023. 3. 27.
728x90

 

참고

2023.03.14 - [네트워크 수업] - [실습] DRP(Dynamic Routing Protocol) - RIP (2) Partial Mesh 23.03.14

 

27.27.0.0 /16 24bit mask

기본 설정 

int s1/0

no shut

encap frame

no frame inver

 

R1]

int loo0

ip add 27.27.1.1 255.255.255.0

int s1/0

ip add 27.27.123.1 255.255.255.0

frame map ip 27.27.123.2 102 br

frame map ip 27.27.123.2 103 br

 

R2]

int loo0

ip add 27.27.2.2 255.255.255.0

int s1/0.123 m

ip add 27.27.123.2 255.255.255.0

frame map ip 27.27.123.1 201 br

frame map ip 27.27.123.3 203 br

 

R3]

int loo0

ip add 27.27.3.3 255.255.255.0

int s1/0.123 m

ip add 27.27.123.3 255.255.255.0

frame map ip 27.27.123.1 301 br

frame map ip 27.27.123.2 302 br

 

int s1/0.34 p

ip add 150.1.34.1 255.255.255.0

frame inter 304

 

R4]

int loo0

ip add 150.1.4.4 255.255.255.0

int s1/0.34 p

ip add 150.1.34.254 255.255.255.0

frame inter 403

 

ping 확인

 


R1]

router eigrp 27

eigrp router-id 27.27.1.1

net 27.27.1.1 0.0.0.0 //루프백에있는 마스크가 자동 적용됨. 근데 이렇게 굳이 해주는 이유? R1,2,3 끼리 서로 변별력 있게 해주려고 hello가 누구건지 서로 확실하게 인식하기 위해 호스트 route를 준다.

되도록이면 eigrp와 osfp는 저렇게 호스트로 주는게 좋다.

net 27.27.123.1 0.0.0.0

no auto

passive-interface lo0 

 

 

R2]

router eigrp 27

eigrp router-id 27.27.2.2

net 27.27.2.2 0.0.0.0

net 27.27.123.2 0.0.0.0

no auto

passive-interface lo0 

 

R3]

router eigrp 27

eigrp router-id 27.27.3.3

net 27.27.3.3 0.0.0.0

net 27.27.123.3 0.0.0.0

no auto

passive-interface lo0 

 

 

router rip

ver 2

net 150.1.0.0

no auto

//passive-interface loo0 - 얘도 굳이 할 필요 없다

 

R2]

int s1/0.123

no ip split-horizon eigrp 27 //R2에서 split horizen desable해서 받았던걸 주게 만들자. 한단자에 두개가 물려있어서 이걸 안해주면 27.27.3.0과 27.27.1.0을 전달 안해준다.

 

 

 

R4]

router rip
ver 2
net 150.1.0.0

passive-interface loo0
no auto

 

 


R3]

sh int s1/0.123

Serial1/0.123 is up, line protocol is up 
  Hardware is M4T
  Internet address is 27.27.123.3/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY
  CRC checking enabled
  Last clearing of "show interface" counters never

 

 

router eigrp 27

redistribute rip metric 1544 2000 255 1 1500 //eigrp 27이 rip 을 자기쪽으로 끌어온다. /이렇게하면 hop수를 자동으로 재정비한다. 알아서 계산한다. / 딜레이는 10으로 나눈다. //BW DLY reliability txload MTU

 

back to metric을 R3에 데려오려고 하는쪽으로 땡겨온다.

 

R1]

R1(config-router)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     27.0.0.0/24 is subnetted, 4 subnets
C       27.27.1.0 is directly connected, Loopback0
D       27.27.2.0 [90/2297856] via 27.27.123.2, 01:17:52, Serial1/0
D       27.27.3.0 [90/2809856] via 27.27.123.2, 00:08:03, Serial1/0
C       27.27.123.0 is directly connected, Serial1/0
     150.1.0.0/24 is subnetted, 2 subnets
D EX    150.1.4.0 [170/3193856] via 27.27.123.2, 00:00:05, Serial1/0
D EX    150.1.34.0 [170/3193856] via 27.27.123.2, 00:00:05, Serial1/0

 

//D EX는 다른곳에서 넘어왔다는 뜻이다.

 

R4] 이제 EIGRP 를 이쪽으로 넘기자

 

R3]

ip prefix-list HOP1 permit 27.27.123.0/24

ip prefix-list HOP1 permit 27.27.3.0/24
ip prefix-list HOP2 permit 27.27.2.0/24  
ip prefix-list HOP3 permit 27.27.1.0/24

 

route-map EIGRP_NET
match ip add prefix HOP1 
set metric 1
route-map EIGRP_NET 20  
match ip add prefix HOP2
set metric 2            
route-map EIGRP_NET 30  
match ip add prefix HOP3
set metric 3  

 

router rip

redistribute eigrp 27 route-map EIGRP_NET //넘긴다.

 

R4(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 150.1.34.1 to network 0.0.0.0

     27.0.0.0/24 is subnetted, 4 subnets
R       27.27.1.0 [120/3] via 150.1.34.1, 00:00:11, Serial1/0.34
R       27.27.2.0 [120/2] via 150.1.34.1, 00:00:11, Serial1/0.34
R       27.27.3.0 [120/1] via 150.1.34.1, 00:00:11, Serial1/0.34
R       27.27.123.0 [120/1] via 150.1.34.1, 00:00:11, Serial1/0.34
     150.1.0.0/24 is subnetted, 2 subnets
C       150.1.4.0 is directly connected, Loopback0
C       150.1.34.0 is directly connected, Serial1/0.34
R*   0.0.0.0/0 [120/1] via 150.1.34.1, 00:00:15, Serial1/0.34

 

//1hop , 2hop, 3hop 제대로 잘 나왔다.

 

 


 

R3 저부분에서 축약을 넘긴다.

 

R3]

int s1/0.34

ip summary-address rip 27.27.0.0 255.255.0.0

 

 

R4]

clear ip route *

show ip route

 

R4#show ip route   
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 150.1.34.1 to network 0.0.0.0

     27.0.0.0/16 is subnetted, 1 subnets
R       27.27.0.0 [120/1] via 150.1.34.1, 00:00:01, Serial1/0.34
     150.1.0.0/24 is subnetted, 2 subnets
C       150.1.4.0 is directly connected, Loopback0
C       150.1.34.0 is directly connected, Serial1/0.34
R*   0.0.0.0/0 [120/1] via 150.1.34.1, 00:00:01, Serial1/0.34  ==>엇..얜 아닌것같음...??!!??

//축약이 되었다.

 

현재는 오바이트현상은 없지만 가끔 자기가 받은걸 다시 내뱉은 오바이트 현상이 있을때가 있다.

★★필터링을 잘해야한다.(prefix..이런거)

728x90

댓글